Adobe CS3 Installation Bug Workaround Discovered

Posted by:
Date: Tuesday, May 1st, 2007, 11:22
Category: How-To

cs3.jpg
Reader Ciro Coelho sent us this workaround when he found himself unable to cleanly install the Design Premium version of its Creative Suite 3 package:
I got problems as soon as I tried to install CS3 Design Premium on a G5 running 10.4.8 with a Photoshop CS3 Beta installed. I checked the web for a solution to the problem, and found the CS3Clean script. I uninstalled Photoshop CS3 beta and the CS3 Design Premium using its uninstalling routines (Utilities folder), ran the CS3Clean script and trashed preferences as instructed by the script read me files. I tried installing CS3 after repeating the same procedure for 2 existing user accounts, as well as having created a fresh one, to no avail. I then called Adobe and they told me to do what I had already tried. The only solution left, which had been successful with other customers, was to archive and install OS X, or ultimately, to clean re-install it before attempting to install CS3.
For obvious reasons I resisted they suggestion, and found A SUCCESSFUL solution:
-Uninstall all CS3 applications (beta and shipping versions).
-Run Adobe’s CS3 Clean script, trash CS3 preferences.
-Mount an external firewire drive.
-Install OS X (I did 10.4.9) onto it.
-Restart and boot up from that firewire drive.
-Insert CS3 CD, install software onto the external drive.
-Restart from your regular internal drive.
-Migrate (Utilities>Migration Assistant) from the firewire drive where you installed a fresh OS X and CS3.
-Restart from that new user account on your regular internal drive. Launch one of the applications from CS3, enter serial number, register computer.
-Login from your regular user account and launch CS3 applications.
If you’ve seen similar instances of this or created your own workaround, let us know.


cs3.jpg
Reader Ciro Coelho sent us this workaround when he found himself unable to cleanly install the Design Premium version of its Creative Suite 3 package:
I got problems as soon as I tried to install CS3 Design Premium on a G5 running 10.4.8 with a Photoshop CS3 Beta installed. I checked the web for a solution to the problem, and found the CS3Clean script. I uninstalled Photoshop CS3 beta and the CS3 Design Premium using its uninstalling routines (Utilities folder), ran the CS3Clean script and trashed preferences as instructed by the script read me files. I tried installing CS3 after repeating the same procedure for 2 existing user accounts, as well as having created a fresh one, to no avail. I then called Adobe and they told me to do what I had already tried. The only solution left, which had been successful with other customers, was to archive and install OS X, or ultimately, to clean re-install it before attempting to install CS3.
For obvious reasons I resisted they suggestion, and found A SUCCESSFUL solution:
-Uninstall all CS3 applications (beta and shipping versions).
-Run Adobe’s CS3 Clean script, trash CS3 preferences.
-Mount an external firewire drive.
-Install OS X (I did 10.4.9) onto it.
-Restart and boot up from that firewire drive.
-Insert CS3 CD, install software onto the external drive.
-Restart from your regular internal drive.
-Migrate (Utilities>Migration Assistant) from the firewire drive where you installed a fresh OS X and CS3.
-Restart from that new user account on your regular internal drive. Launch one of the applications from CS3, enter serial number, register computer.
-Login from your regular user account and launch CS3 applications.
If you’ve seen similar instances of this or created your own workaround, let us know.

Recent Posts