Adobe releases Acrobat Reader, Pro 9.3.4 versions, patches security holes

Posted by:
Date: Friday, August 20th, 2010, 05:21
Category: News, Software

On Thursday, Adobe released a long-awaited patch that addresses a number of vulnerabilities in versions of its Acrobat Pro and Reader offerings.

The updates, which can also be snagged through the Adobe Update Utility, address security vulnerabilities while providing additional stability.

Acrobat Reader 9.3.4 and Acrobat Pro requires an Intel or PowerPC-based processor and Mac OS X 10.4 or later to install and run.

If you’ve tried the new versions and noticed any differences, please let us know what you think.

Recent Posts