Adobe releases Acrobat Reader, Pro 9.4 versions, patches security holes

Posted by:
Date: Wednesday, October 6th, 2010, 04:06
Category: News, Software

Late Tuesday, Adobe released version 9.4 of its Adobe Reader and Acrobat Pro applications. The updates, which can also be snagged through the Adobe Update Utility, address security vulnerabilities while providing additional stability.

Acrobat Reader 9.4 and Acrobat Pro requires an Intel or PowerPC-based processor and Mac OS X 10.4 or later to install and run.

If you’ve tried the new versions and noticed any differences, please let us know what you think.

Recent Posts