Aperture Update Squeezes Older Systems

Posted by:
Date: Thursday, May 25th, 2006, 12:00
Category: Software

aperture-box-200.jpgI wanted to bring to your attention a major problem Aperture users are experiencing. Like many others when Aperture was released I ordered a new PowerMac to be able to run Aperture. At the time the nVIDIA GeForce 6600 was a recommended video card.
With the release of Aperture 1.1 the minimum system requirements have jumped up quite a bit.
While he GeForce 6600 is still “supported” with 1.1 the issue is that it used to be a “recommended” card with Aperture 1.0 and now it is part of the “minimum system requirements” just barely making the minimum. I purchased the PowerMac specifically to use with Aperture.
While I do not expect Apple to maintain full backwards system compatibility I think this is certainly excessive. As it currently stands Aperture is painfully slow and all indications are the only fix is upgrading my graphics card to the GeForce 7800 GT.
Unfortunately Apple will not sell this card alone nor do they provide an upgrade path. I along with many other users have discussed this on the Aperture mailing list and we are hoping to group together a sufficient number of users to help encourage Apple to offer an upgrade option to the GeForce 7800 or take my system back and I will order a new one with the GeForce card. The discussion is available online at here.
Contributed by: Alex Rodriguez


aperture-box-200.jpgI wanted to bring to your attention a major problem Aperture users are experiencing. Like many others when Aperture was released I ordered a new PowerMac to be able to run Aperture. At the time the nVIDIA GeForce 6600 was a recommended video card.
With the release of Aperture 1.1 the minimum system requirements have jumped up quite a bit.
While he GeForce 6600 is still “supported” with 1.1 the issue is that it used to be a “recommended” card with Aperture 1.0 and now it is part of the “minimum system requirements” just barely making the minimum. I purchased the PowerMac specifically to use with Aperture.
While I do not expect Apple to maintain full backwards system compatibility I think this is certainly excessive. As it currently stands Aperture is painfully slow and all indications are the only fix is upgrading my graphics card to the GeForce 7800 GT.
Unfortunately Apple will not sell this card alone nor do they provide an upgrade path. I along with many other users have discussed this on the Aperture mailing list and we are hoping to group together a sufficient number of users to help encourage Apple to offer an upgrade option to the GeForce 7800 or take my system back and I will order a new one with the GeForce card. The discussion is available online at here.
Contributed by: Alex Rodriguez

Recent Posts

Comments are closed.