Apple blocks older Flash plug-in version if Safari, pushes users to adopt new, more secure, version

Posted by:
Date: Friday, July 11th, 2014, 11:51
Category: News, security, Software

flashplayericon

You may not like doing it, but you’re going to have to snag the newest version of Adobe’s Flash Player plug-in.

Per AppleInsider, Apple late Thursday issued a security message saying it has blocked old versions of Adobe’s Flash Player plug-in for Safari, citing a recent flaw that could potentially allow hackers to harvest browser data like cookies.

Users with out of date plug-ins will be met with a message saying, “Blocked plug-in,” “Flash Security Alert” or “Flash out-of-date” when attempting to access Flash content in Safari. Clicking on the alert takes users to Adobe’s Flash installer page, where the latest version of the plug-in can be downloaded and installed.


According to Adobe, the flaw can be found in Flash Player for Mac version 14.0.0.125 and earlier. After a proof-of-concept exploit was demonstrated by Google engineer Michele Spagnuolo, Adobe advised Mac users to update to version 14.0.0.145. Aside from OS X, Windows and Linux builds of Flash were also affected by the bug.

Users who need to run older, flawed versions of Flash may do so by configuring Safari’s plug-in management settings to allow specific websites to “Run in Unsafe Mode.” Re-enabling older Flash versions requires Safari 6.1 or later.

Stay tuned for additional details as they become available.

Recent Posts