Apple Warns iPhone App Developers to be Compatible with iPhone OS 3.0

Posted by:
Date: Friday, May 15th, 2009, 07:40
Category: iPhone

3giphone.jpg
Earlier this week, Apple officially warned its iPhone/iPod touch application developer base that all applications submitted for iTunes App Store approval must be iPhone OS 3.0-compliant. Per Computerworld, Apple sent an e-mail to registered iPhone developers stating that all new apps will be tested for approval on the latest beta version of 3.0. It said it may also remove any apps currently in the App Store if they do not work on the iPhone’s new operating system.
Current speculation about the demand is pointing towards Apple wanting to ensure that the new parental controls feature for iPhone applications uncovered in the latest beta of iPhone OS 3.0 are functional. The parental controls feature would allow Apple to offer a wider variety of content and restrict more explicit material based on an iPhone user’s age.
On Wednesday, Apple released its fifth beta version of the latest iPhone OS — a final version of 3.0 is expected to be ready in time for Apple’s Worldwide Developers Conference in San Francisco next month.

Recent Posts