Camino updated to 2.1.1

Posted by:
Date: Wednesday, February 22nd, 2012, 07:19
Category: News, Software

caminologo.jpg

Late Wednesday, the Camino Project released version 2.1.1 of Camino, its free, open source web browser.

The new version, an 18.5 megabyte download, adds the following fixes and changes:

– Upgraded to version 1.9.2.27 of the Mozilla Gecko rendering engine, which includes several critical security and stability fixes.

– Blocked versions of Adobe Flash Player 10 older than 10.3.183.15 and Flash Player 11 older than 11.1.102.62 on Intel Macs due to severe security issues.

– Tweaked the autocomplete algorithm to reduce the weight of visit count.
Added a hidden preference to allow turning off autocomplete’s use of page titles in matches.

– The location sheet once again shows an autocomplete window.

– It is now possible to clear the “Recently Closed Pages” menu with the “Clear History…” menu item even when history is disabled.

– Improved the appearance of the bookmark toolbar in background windows on Mac OS X 10.7.

– On Mac OS X 10.7, Camino now appears in the “Productivity” category when sorting Finder windows by category.

– Camino now correctly checks for the presence of a Java plug-in on Mac OS X 10.7.

– The “open location” AppleScript command now supports optional “referrer” and “loading in background” parameters.

– Camino will now display an error message when the “open location” command’s direct parameter is empty or missing.

– A new “reload” command allows AppleScripts to reload browser windows and tabs.

– The status of Camino’s offline mode is now available to AppleScript, and scripts can toggle offline mode on and off using the application object’s “online” property.

– The AppleScript “visit count” bookmark property once again works correctly.

– Pressing Escape will now cancel Tab Overview.

– “Fill Form” no longer fills disabled hidden form controls.

– The “Block Flash animations” checkbox is no longer enabled if Flash is not installed.

– Camino now correctly resolves Bonjour services that do not include an initial forward slash in their “path” information.

Camino 2.1.1 requires Mac OS X 10.4 or later to run.

If you’ve tried the new version of Camino and have any kind of feedback about it, let us know.

Recent Posts