CrossOver updated to 11.3

Posted by:
Date: Tuesday, November 6th, 2012, 08:57
Category: News, Software

CrossOver, the popular virtualization program from CodeWeavers, has been updated to version 11.3. The new version, a 69.8 megabyte download, is available as a demo, offers the following fixes and changes:

Complete translations for:
- Czech.

- Spanish.

- Japanese.

- Polish.

- Portuguese (Brazil).

- Chinese (China).

- Fix for font rendering in Civ IV.

CrossOver 11.3 retails for US$59.95 and requires Mac OS X 10.5 and or later and an Intel-based Mac to install and run.

If you’ve tried the new version and have any feedback to offer, please let us know in the comments.

Recent Posts