Google Chrome updated to 21.0.1180.75

Posted by:
Date: Wednesday, August 8th, 2012, 13:31
Category: News, Software

google-chrome-logo

Hey, updates are useful.

On Wednesday, Google released version 21.0.1180.75 of its Chrome web browser. The update, a 40.7 megabyte download, adds the following fixes and changes:

– Flash videos not longer remaining in fullscreen when clicking a secondary monitor while the video is playing (Issue: 140366).

– Flash video full screen displays on wrong monitor (Issue: 137523).

– REGRESSION: Rendering difference in Chrome 21 and 22 that affected on Persian Wikipedia (Issue: 139502).

– Some known crashes (Issues: 137498, 138552, 128652, 140140).

– Audio objects are not “switched” immediately (Issue: 140247).

– Print and Print Preview ignore paper size default in printer config (Issue: 135374).

– Candidate windows is shown in wrong place in Retina display (Issue: 139108)
more of the choppy and distorted audio issues (Issue: 136624).

– Japanese characters showing in Chinese font (Issue: 140432).

– Video playback issues with flash-based sites (Issue: 139953).

– Sync invalidation notification broken after restart (Issue: 139424).

Google Chrome 21.0.1180.75 requires an Intel-based Mac with Mac OS X 10.5 or later to install and run. If you’ve tried the new version and have any feedback to offer, please let us know in the comments.

Recent Posts

3 Responses to “Google Chrome updated to 21.0.1180.75”

  1. they still didn’t fix the hover issue!
    when you hover quickly over youtube like/dislike buttons, black rectangles remain on the screen!

  2. The bottoms of letters (like j, g, y) are cut off when I type replies in gmail. Voice is out of sync with mouths on You Tube videos. Finance data on left side of page no longer lines up. There are problems!

  3. I’m having some troubles with using background-image with 8 bits .png. It looks like a render problem since i resize the browser it starts working. Tracking down the problem i see that only started to happen on this 21.0.1180.75 Chrome m version. Anybody with the same problem?