Parallels Desktop updated to 7.0.14924.699487

Posted by:
Date: Friday, October 7th, 2011, 05:00
Category: News, Software

parallelslogo1.jpg

On Thursday, Parallels released version 7.0.14924.699487 of its Parallels Desktop virtualization software. The new update, a 289 megabyte download, adds the following fixes and changes:

- Add support for Windows 8 Developer Preview (new Windows 8 installation is recommended after installing the update).

- Improve compatibility with Quicken 2011.

- Improve support for Autodesk 3ds Max 2012.

- Optimize CPU usage when Parallels Desktop is idle.

Parallels Desktop 7 retails for US$79.99 and requires a 64-bit Intel-based processor, Mac OS X 10.5.8 or later, 2GB of RAM (4GB recommended to run Windows 7), at least 700 MB of space available on the boot volume for Parallels Desktop installation and 15 GB of available disk space for Windows.

If you’ve tried the new version and have any feedback to offer, let us know in the comments.

VirtualBox updated to 4.1.4

Posted by:
Date: Tuesday, October 4th, 2011, 03:58
Category: News, Software

virtualbox.png

VirtualBox, an open source x86 virtualization project available for free has just hit version 4.1.4. The new version, a 88.9 megabyte download, sports an extensive list of changes that can be found here.

VirtualBox 4.1.4 is available for free and requires Mac OS X 10.4 or later and an Intel-based Mac to install and run.

If you’ve tried the new version and have any feedback, please let us know.

Mozilla releases Firefox 7.0.1 update

Posted by:
Date: Friday, September 30th, 2011, 05:43
Category: News, Software

elfirefox

On Monday, Mozilla.org released version 7.0 of its Firefox web browser. The new version stands as an 28.2 megabyte download offered the following change:

- Fixed a rare issue where some users could find one or more of their add-ons hidden after a Firefox update.

Firefox 7.0.1 requires an Intel-based Mac and Mac OS X 10.5 or later to install and run.

If you’ve tried the new version and have any feedback, let us know.

Adobe releases Lightroom 3.5 update

Posted by:
Date: Thursday, September 29th, 2011, 10:44
Category: News, Software

adobeicon

On Thursday, software giant released version 3.5 of its Lightroom (available on the company’s update page) photo editing utility. The Lightroom 3.5 update added the following fixes and changes:

- Using the arrow keys to modify image adjustment settings lacked responsiveness.

- A Publish Collection targeting a hard drive on Windows would not behave properly if the designated folder was deleted from hard drive.

- After editing the capture time in Lightroom, “Date Time Digitized” was incorrectly changed (Only “Date Time Original” should be modified).

- On Windows computers, Lightroom would interpret the wrong time zone.

- Changing Lightroom’s date created field to a date prior to 1933 resulted in unexpected values.

- Lightroom 3.2 introduced preview cache inefficiencies.

- GPS Altitude metadata was incorrectly excluded from files converted to DNG or exported as DNG files from Lightroom 3.4.1.

- For non-English language operating systems, folder names in the import dialog may not
have been translating properly.

- When exporting images with the “Write Keywords as Lightroom Hierarchy” enabled,
keywords with “Include on Export” deselected would still have been included on export • Saving metadata to a JPEG file in Lightroom 3.4 could have caused Lightroom to quit
unexpectedly.

- A Publish Collection in Lightroom 3.4 set to publish original files would fail to include XMP files for proprietary raw formats.

- RECONYX images did not open properly in Lightroom 3.4.

- When applying automatic lens profile correction, Lightroom 3.4 did not automatically
recognize the following lens: “Nikon AF-S NIKKOR 24mm f/1.4G ED”.

- Using the plus or minus key to increment Develop Module parameters did not work
properly on the Mac.

- The Limit File Size export option was incorrectly including EXIF metadata on export when the Minimize Embedded Metadata option was selected.

- On Mac OS X 10.7, the Lightroom import dialog did not properly display network volumes.

- On Windows computers, using Shift + Scroll wheel to adjust the Adjustment Brush feather size, the expected result of the scroll wheel movement was reversed.

- Lightroom would not provide the correct error message when attempting to delete photos published to Facebook.

- Lightroom would experience tether capture failures on computers utilizing OS X 10.6.8 and 10.7.

- Develop load time performance was inconsistent.

Adobe Lightroom 3.5 retails for US$299 and requires Mac OS X 10.5 or later to install and run.

VMWare releases Fusion 4.0.2 update

Posted by:
Date: Thursday, September 29th, 2011, 04:46
Category: News, Software

vmwarelogo.jpg

On Thursday, virtualization softare maker VMWare released version 4.0.2 of its Fusion software for the Mac.

Similar to other virtualization software packages, VMWare allows users to run alternate operating systems such as Windows and Linux distributions on Intel-based Macs at native speeds. Other features, such as Unity, allow users to run and minimize Windows applications from the Mac OS X Dock.

The new version, a 180 megabyte download via MacUpdate, can be found here, offers the following fix:

- Addresses an issue starting virtual machines running a forthcoming version of Mac OS X Lion.

Fusion 4.0.2 retails for US$49.99 and requires an Intel-based Mac, 2 GB of RAM, Mac OS X 10.6.7 or later (10.7 recommended) and a copy of Windows (if you’ll be installing Windows).

If you tried the new version and have any feedback, please let us know in the comments.

Mozilla releases Firefox 7.0 update

Posted by:
Date: Monday, September 26th, 2011, 10:07
Category: News, Software

elfirefox

On Monday, Mozilla.org released version 7.0 of its Firefox web browser. The new version stands as an 28.2 megabyte download offered the following fixes and changes:

- Drastically improved memory use.

- Added a new rendering backend to speed up Canvas operations on Windows systems.

- Bookmark and password changes now sync almost instantly when using Firefox Sync.

- Added support for text-overflow: ellipsis.

- Added support for the Web Timing specification.

- Added an opt-in system for users to send performance data back to Mozilla to improve future versions of Firefox. This can be enabled by installing an add-on.

- Fixed several stability issues.

Firefox 7.0 requires an Intel-based Mac and Mac OS X 10.5 or later to install and run.

If you’ve tried the new version and have any feedback, let us know.

Delicious Library updated to 2.7.1

Posted by:
Date: Friday, September 23rd, 2011, 05:31
Category: News, Software

deliciouslogo

On Wednesday, software company Delicious Monster released version 2.7.1 of the shareware favorite, Delicious Library. Delicious Monster allows Macs with webcams to scan the bar codes of any book, movie, music CD or video game, then creates an archive based on background information from the Internet. Additional features help keep the library organized and reseller’s tools allow for items to be quickly posted for sale online.

The update, a 16.4 megabyte download, adds the following fixes and changes:

- Fixed a crash on the lookup activity panel (only affected 10.7).

- Fixed some loaned items not displaying on friends (only affected pre-10.7).

- Fixed a crash when dragging a loaned item from one friend to another.

- Refreshing an item with an EAN but not ASIN connects it with its details.

- Fixed some broken links in our help (sorry about that!)

Delicious Library 2.7.1 retails for US$40 and requires Mac OS X 10.5 or later to install and run.

Apple releases Thunderbolt Software Update 1.0

Posted by:
Date: Friday, September 16th, 2011, 09:22
Category: News, Software

Maybe it’s a good thing that the software patch arrived before the actual units did. On Friday, Apple released Thunderbolt Software Update 1.0, a 60.3 megabyte download that provides support for the Apple Thunderbolt Display and bug fixes for Thunderbolt device compatibility.

The update should also be available via Mac OS X’s Software update feature and requires Mac OS X 10.7.1 to install and run.

If you’ve received your Apple Thunderbolt Display yet and tried the update with it, please let us know what you make of it via the comments.

Parallels Desktop updated to 7.0.14922.693916

Posted by:
Date: Thursday, September 15th, 2011, 05:35
Category: News, Software

parallelslogo1.jpg

Updates: They tend to be useful.

Late Wednesday, Parallels released version 7.0.14922.693916 of its Parallels Desktop virtualization software. The new update, a 289 megabyte download, adds the following fixes and changes:

- New interface languages, including Czech, Portuguese, Chinese Simplified, and Chinese Traditional.

- Option to choose Mac OS X Snow Leopard-style full screen mode instead of native OS X Lion full screen mode.

- Better compatibility with FileVault.

- Improved compatibility with FaceTime HD camera and other USB devices for virtual machines with more than 2 GB of memory.

- Resolves a problem with Mac slow boot time.

Parallels Desktop 7 retails for US$79.99 and requires a 64-bit Intel-based processor, Mac OS X 10.5.8 or later, 2GB of RAM (4GB recommended to run Windows 7), at least 700 MB of space available on the boot volume for Parallels Desktop installation and 15 GB of available disk space for Windows.

If you’ve tried the new version and have any feedback to offer, let us know in the comments.

Microsoft Office 2008 updated to 12.3.1, adds Word, Entourage changes

Posted by:
Date: Wednesday, September 14th, 2011, 12:45
Category: News, Software

microsoftlogo.jpg

Microsoft has posted an update to version 12.3.1 for Office 2008 for Mac. The update, a 333 megabyte download, offers the following fixes and changes:

Improvements for Microsoft Word 2008 for Mac:
Help works in all languages – This update resolves an issue that causes online Word Help not to display in some languages.

Improvements for Microsoft Entourage 2008 for Mac:
Time zone information is updated – This update provides updated time zone information.

Microsoft Office 2008 12.3.1 requires Mac OS X 10.4.9 or later to install and run.

If you’ve tried the update and have anything to report back, let us know.